Múltiples vulnerabilidades en Moodle

Múltiples vulnerabilidades en Moodle

Fecha de publicación: 

16/11/2021

Importancia: 

5 - Crítica

Recursos afectados: 

Las versiones de Moodle que se ven afectadas son las siguientes:

  • de la 3.11 a la 3.11.3,
  • de la 3.10 a la 3.10.7,
  • de la 3.9 a la 3.9.10,
  • versiones anteriores no soportadas.

Descripción: 

Se han publicado cinco vulnerabilidades en Moodle, tres de severidad crítica y el resto de severidad baja, que podrían permitir a un atacante ejecutar código de forma remota y realizar ataques de tipo XSS reflejado o CSRF. 

Solución: 

Aplicar las siguientes actualizaciones, en función de la versión afectada:

  • 3.11.4,
  • 3.10.8,
  • 3.9.11.

Detalle: 

  • Al restaurar archivos de backup con un formato erróneo, un atacante podría ejecutar código de forma remota. Se ha asignado el identificador CVE-2021-3943 para esta vulnerabilidad crítica.
  • Un parámetro URL en la herramienta de administrador filetype es vulnerable a ataques de tipo XSS reflejado. Se ha asignado el identificador CVE-2021-43558 para esta vulnerabilidad crítica.
  • La falta del token de comprobación en la función delete related badge hace vulnerables a las versiones afectadas a ataques CSRF. Se ha asignado el identificador CVE-2021-43559 para esta vulnerabilidad crítica.

Para una de las vulnerabilidades de severidad baja se ha asignado el identificador CVE-2021-43560.

Referencias: 

MSA-21-0038: Remote code execution risk when restoring malformed backup file

MSA-21-0039: Upgrade moodle-mlbackend-python and update its reference in /lib/mlbackend/python/classes/processor.php (upstream)

MSA-21-0040: Reflected XSS in filetype admin tool

MSA-21-0041: CSRF risk on delete related badge feature

MSA-21-0042: IDOR in a calendar web service allows fetching of other users' action events

Comentarios (0)

Deja un comentario



Categorias


Por fecha


Listed on WHTop.com
Dejanos tu opinión: Enlace